OpenRoads Designer CONNECT Edition SDK Help

CreateTangentLineWithLength Method

Constructs a profile Line element tangent to a profile element with length.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  ProfileLine[]CreateTangentLineWithLength( ProfileElement elmt, DPoint3d thruPoint,double projectLength)

Parameters

SettingDescription
  ProfileElement The profile element which the created profile line is tangent to.
  DPoint3d The through passing point of the profile line
   The projected length of the profile line

Return Value

ProfileLine[] The tangent profile line elements cli::array

See Also